User talk:Phlip/Greasemonkey

From Homestar Runner Wiki

(Difference between revisions)
Jump to: navigation, search
m (subtitles stopped working: fix link)
(subtitles stopped working)
Line 326: Line 326:
I just noticed it today.  I used it and it worked fine the other day.  It seems that the script isn't finding the list of languages at [[Subtitles:Languages]] (the Subtitles Language select box doesn't have any entries).  I do have AdBlock Plus but disabled it temporarily with no change.  I'm using Firefox 3.0.11 with Greasemonkey 0.8.20090123.1 and the newest All-in-one script from [[User:Phlip/Greasemonkey]] (3.2.7).  Perhaps it's related to "We will be making adjustments to the server throughout the evening, including upgrading to MediaWiki 1.15."?  See also [[HRWiki_talk:Subtitles#Subitles_Not_Working?]] --[[User:Mini-Geek|Mini-Geek]]<sup>[[User_talk:Mini-Geek|t]] [[Special:Contributions/Mini-Geek|c]]</sup> 03:11, 13 June 2009 (UTC)
I just noticed it today.  I used it and it worked fine the other day.  It seems that the script isn't finding the list of languages at [[Subtitles:Languages]] (the Subtitles Language select box doesn't have any entries).  I do have AdBlock Plus but disabled it temporarily with no change.  I'm using Firefox 3.0.11 with Greasemonkey 0.8.20090123.1 and the newest All-in-one script from [[User:Phlip/Greasemonkey]] (3.2.7).  Perhaps it's related to "We will be making adjustments to the server throughout the evening, including upgrading to MediaWiki 1.15."?  See also [[HRWiki_talk:Subtitles#Subitles_Not_Working?]] --[[User:Mini-Geek|Mini-Geek]]<sup>[[User_talk:Mini-Geek|t]] [[Special:Contributions/Mini-Geek|c]]</sup> 03:11, 13 June 2009 (UTC)
:It's related to the [[HRWiki:Upgrade to MediaWiki 1.15|new upgrade]] and the move to the /wiki/ URLs... it should be fixed now. The script should automatically prompt you to update it sometime in the next day or so, or you can just hit the install link on [[User:Phlip/Greasemonkey|the script page]] to do it yourself. If you're still not getting subtitles, it could be because you hit the "Save" or "Clear cache" buttons in the config panel while the subtitles were broken... in that case, just open up the config panel, make sure that the "language" option is set, and hit save. That should bring them back. {{User:Phlip/sig}} 16:27, 13 June 2009 (UTC)
:It's related to the [[HRWiki:Upgrade to MediaWiki 1.15|new upgrade]] and the move to the /wiki/ URLs... it should be fixed now. The script should automatically prompt you to update it sometime in the next day or so, or you can just hit the install link on [[User:Phlip/Greasemonkey|the script page]] to do it yourself. If you're still not getting subtitles, it could be because you hit the "Save" or "Clear cache" buttons in the config panel while the subtitles were broken... in that case, just open up the config panel, make sure that the "language" option is set, and hit save. That should bring them back. {{User:Phlip/sig}} 16:27, 13 June 2009 (UTC)
 +
::Thanks, it works now. :) --[[User:Mini-Geek|Mini-Geek]]<sup>[[User_talk:Mini-Geek|t]] [[Special:Contributions/Mini-Geek|c]]</sup> 20:34, 13 June 2009 (UTC)

Revision as of 20:34, 13 June 2009

Troubleshooting

If the script doesn't seem to be working for you, please try:

  1. If you have Adblock, Flashblock, or similar addons installed, disable them on homestarrunner.com.
  2. Reinstalling the script, by clicking this link.
  3. Uninstalling Greasemonkey (from the Tools menu in Firefox, choose Add-ons, then go to the Extensions section, click Greasemonkey, then Uninstall), and then reinstall it (from here). You'll probably need to [install the script again.

If you're still having problems after that, then ask for help on this page. Be sure to mention what versions of Firefox and Flash you have, and what other extensions you have installed. --phlip TC 03:26, 11 October 2008 (UTC)

Release notes

Version 1.0 (8 Mar, 2006)

  • First released version.
  • Had the fullscreen, seek bar, prev/next and wiki link features.
  • Worked only on the main site.

Version 2.0 (26 May, 2006)

  • Added the preferences menu.
  • Added support for Videlectrix and the HRWiki mirror.
  • Added "outside the frame", April Fools and plain HTML navbar options.

Version 2.1 (8 Aug, 2006)

  • Tooltips in the preferences box.
  • The "more better" rando link is now always on... the less better version was just ugly, so I removed it.
  • You can set what types of toon are included in the rando selection.
  • You have the option to make it check if the next sbemail/whatever actually exists before putting the "next" link (so there's no "next" link on the latest email).
    • The only reason this wasn't there before is that it means an extra hit to the H*R servers... but now that I have the preferences things set up, so you can turn it on or off, I think that's fine.

Version 3.0 (29 Aug, 2006)

  • Added subtitling functionality.
  • Updating no longer requires uninstalling the previous version.

Version 3.1 (27 Sep, 2006)

  • Whether to show the names next to subtitles is now a distinct setting from the one for colours - you can have neither, either or both.
  • There is a button that will purge the local cache for all subtitles-related files downloaded from the wiki and reload the page, for when the cache is out of date.
  • The ability to update the test subtitles without refreshing the page for every change (NB: disabled by default, see below).
  • Rewind and fast forward buttons on the seek bar to go to the first/last frame, respectively.
  • Flash loading progress bar on the seek bar (see how much it's loaded).

Version 3.2 (25 Sep, 2007)

  • Add option to automatically check for script updates (on by default).

Contents


Suggestion

Would it make sense to change line 272 to

		addHRWikiLink("Index_Page");

Then I suppose line 261 could be removed. By the way, amazing work Phlip. -- Tom 17:25, 7 March 2006 (UTC)

I suggest that the games on videlectrix.com should be added, such as

http://www.videlectrix.com/duckguard1.html
http://videlectrix.com/duckguard1.html
http://www.videlectrix.com/racewalk.html
http://videlectrix.com/racewalk.html
http://www.videlectrix.com/hallrunner.html
http://videlectrix.com/hallrunner.html
http://www.videlectrix.com/lcd_game.html
http://videlectrix.com/lcd_game.html
http://www.videlectrix.com/thydungeonman2.html
http://videlectrix.com/thydungeonman2.html

And yeah, you rock. Libertyernie 16:32, 8 April 2006 (UTC)

Hmm, that's a good point... I'll get on that sometime (probably tomorrow). --phlip TC 16:37, 8 April 2006 (UTC)
The reason I thought of this was because I realized the Pause button on the seekbar can be used for skipping a level in Duck Guardian. Libertyernie 21:47, 12 April 2006 (UTC)

Homestar-Fullon Edit

Using the user script I was getting a scrollbar on every page, so I edited line 411 from

var dh = window.innerHeight - 10;

to

var dh = window.innerHeight - 20;

This kept all the content in the window, but I didn't have to scroll down to see the navbar at the bottom. Did this happen to anyone else? Consonance 08:39, 23 June 2006 (UTC)

Not me. Works perfectly for me. --Y2K (15px-Crystal_Clear_app_xchat.png15px-Crystal_Clear_app_kedit.png15px-Crystal_Clear_app_email.png) 03:04, 14 July 2006 (UTC)

Eventual to-do list

(in no particular order)

  • Done General cleanup of the code.
  • Done Work on Videlectrix.
  • Done Work on the mirrors (kitkorp (not needed with Tom working on completing the HRWiki mirror) and HRWiki).
  • Done Some way of turning various features on and off maybe?
  • Done replace the navbar with text links (this is more for me than for you guys).
  • Done resize the seek bar when the toon resizes (if you resize the window)
  • Done show outside-the-frame stuff

Feel free to add suggestions. --phlip TC 21:38, 9 April 2006 (UTC)

I've got one. You could try "flipping the whole page upside down". You know, using the flipped navbar, too. And putting the navbar above the flipped toon/game.
Also, you could try adding A-B repeat to the seek bar, if you know enough to do that. Preferably make it a seperate sub-option in the prefs, too.
Totally not getting old, Y2K (15px-Crystal_Clear_app_xchat.png15px-Crystal_Clear_app_kedit.png15px-Crystal_Clear_app_email.png) 22:57, 5 June 2006 (UTC)

Errors in installing

I keep getting this error:

Error installing user script:

[Exception... "Compoment returned failure code: 0x804b000a [nsIIOService.newChannel]" nsresult: "0x804b000a (<unknown>)" location: "JS frame :: chrome://strongbademailsprevnext/content/browser.xul :: getContents :: line 20" data: no]

Any suggestions? —NFITC1talk 07:56, 16 August 2006 (UTC)

"strongbademailsprevnext"? I'm guessing you have this extension installed? You might want to uninstall that... this script does that stuff too. --phlip TC 08:01, 16 August 2006 (UTC)
Nope. I only have the script that allows it to be viewed 'full-screen'. —NFITC1talk 22:34, 16 August 2006 (UTC)
Nevermind. Turns out that they were both conflicting and I was misinterpreting the second error message. Thanks! —NFITC1talk 22:40, 16 August 2006 (UTC)

Just as a side-note for people who run into the same problem I did: if you use a program that blends its own Javascript functions into every page you load (mainly found in ad-munching software, like Ad Muncher), make sure you disable it BEFORE installing the Greasemonkey script. Otherwise the extra code might break it, requiring you to clear your cache and install it again with the filters disabled. MNGoldenEagle 14:24, 28 September 2006 (UTC)

HOW THE HECK!?!?!?!?!

HOW DID YOU MAKE THIS!?!?! TheThin 00:36, 18 September 2006 (UTC)

Phlip has studied necromancy and sorcery for many years now. Other than that, it's a good diet, exercise, and a modicum of good fortune. Qermaq - (T/C) Image:Qermaqsigpic.png 00:44, 18 September 2006 (UTC)
Phlip has access to both a monkey and a typewriter, so it really was only a matter of time. — It's dot com 00:46, 18 September 2006 (UTC)
No, no, no... I sold my soul to Haxxina, ancient Greek goddess of programming and ruler of the underworld. In return She gave me the ability to write this script as my superpower. Just don't make me say my name backwards minus the first 'P' and we should be fine. --phlip TC 00:52, 18 September 2006 (UTC)
We'll be out a free lunch special? Qermaq - (T/C) Image:Qermaqsigpic.png 00:58, 18 September 2006 (UTC)

Refresh Subtitles

OK, this feature will need some explaining... First, go Tools→Manage User Scripts, click on "Homestar All-in-one" and click "Edit". If it asks you to choose a text editor, just pick Notepad unless you have something better. It'll look ugly in Notepad (it doesn't recognise the line endings) but it'll work. Now search for if (settings.testsubs && false) and change it to if (settings.testsubs && true). Now you can use the feature. First you have to turn on "Test subtitles" and hit "Save and apply" as usual, but the next time after the page loads there'll be a "Refresh Subtitles" button below the text area, that re-parses the subtitles without reloading the page - invaluable to subtitle authors.

The reasons the option's not avaliable by default are:

  • The interface is clumsy... sometimes the button's there, sometimes it's not there... depending on whether the test subtitles were already enabled before the page loaded... given it's something that's supposed to update stuff without a page load it can be confusing.
  • It's not exhaustively tested, and has some weird side-effects (it calls savesettings, so if you, say, turn off the seekbar and hit "Reload Subtitles" the seekbar will remain, but it'll save that you want the seekbar turned off)...
  • It's not permanent... Version 4.0 will hopefully make it so that all settings work like this, and clicking "Save and Apply" won't have to reload the page.

So it's there if you want it, but it's not cluttering up the settings boxes of people that don't want it.

Anyways, enjoy! --phlip TC 03:30, 27 September 2006 (UTC)

Greasemonkey install method

GM's changed the way it installs scripts by link. A single-click on the link will offer to install the script, the option isn't even on the right click menu anymore. --AndrewNeo 17:20, 31 October 2006 (UTC)

Just the seek bar

Maybe for use on other sites, you could individually release the code for the seekbar. (And, if possible, include the preferences from the whole script, plus maybe external CSS skin support.) --Y2K (15px-Crystal_Clear_app_xchat.png15px-Crystal_Clear_app_kedit.png15px-Crystal_Clear_app_email.png) 04:00, 16 January 2007 (UTC)

spellcheck

"Homestar" is misspelled in the warning section of the heap-o-comments at the beginning. Page is locked or I'd fix it myself. — User:ACupOfCoffee@ 07:08, 22 February 2007 (UTC)

Uniformity matters... again

Since "podcast" was added recently to the navbar, can you please update that? --Addict 2006 20:55, 2 March 2007 (UTC)

Done. --phlip TC 10:54, 4 March 2007 (UTC)

Is it just me or is this broken?

One day the fullon part stopped working for me. And the Subtitles. And the seek bar. The corner buttons are still there. --68.55.198.213 11:57, 13 June 2007 (UTC)

It's still working fine for me. What did you do the day that it broke? Did you install any other extensions, or scripts, or upgrade anything? --phlip TC 12:03, 13 June 2007 (UTC)
So It's just me. That's good to know. I poked around in the system, and determined an update to flashblock borked it. I normally don't unblock flash (even for homestarrunner.com). Adding it to the whitelist fixed the problem. Before that update, they both worked together. Thanks, and I hope this info helps someone.--68.55.198.213 13:11, 21 June 2007 (UTC)

Not working in nightly build =(

In the nightly build of Firefox (Dubbed Minefield), the script has limited functionality. The subtitle language selector doesn't work, as there are no options. I will try to clean up to make it work..right.

onekopaka 02:14, 5 July 2007 (UTC)

By design, if subtitles are turned off, the script doesn't contact the wiki at all. When you turn the subtitles on, it tries to download the list of supported languages then. The list is empty until that finishes (I suppose I should put a "Loading..." message in there...). So wait a bit, see if it turns up. Failing that, it is a nightly build after all, you should expect some things to be broken... the name "Minefield" isn't just for show... chances are, it's a problem with either GM_xmlhttpRequest or DOMParser... and if so, then it's either a Firefox issue or a GreaseMonkey issue, and there's little I can do about it. --phlip TC 03:15, 5 July 2007 (UTC)
After looking in a Debug Console, the blame goes to..... Greasemonkey! onekopaka 06:40, 17 November 2007 (UTC)
Firefox 3's document.getElementById is changed so that it returns the first object. If you're using it, you might want to read up on MDC (http://developer.mozilla.org/) --24.17.113.45 06:50, 9 May 2008 (UTC)

Typo...

You mispelled automatically. Don't press that button. 10:08, 20 July 2007 (UTC)

I somehow think that's intentional. DEI DAT VMdatvm center\super contra 11:05, 20 July 2007 (UTC)
If you're referring to "automagically", then yes, that's intentional. --phlip TC 04:24, 21 July 2007 (UTC)

Podcast/Podstar

	addnavbarlink(newnavbar, "http://www.homestarrunner.com/toons.html", "Toons");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/games.html", "Games");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/characters2.html", "Characters");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/downloads.html", "Downloads");
	addnavbarlink(newnavbar, "http://homestarrunner.stores.yahoo.net/", "Store");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/sbemail.html", "SB Emails");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/email.html", "Contact");
	addnavbarlink(newnavbar, "http://podstar.homestarrunner.com/", "Podstar");
	addnavbarlink(newnavbar, "http://www.homestarrunner.com/legal.html", "Legal");
	randolink = addnavbarlink(newnavbar, "javascript:alert('rando.xml not loaded yet... be patient')", "Rando");


Where it says Podstar, it should say Podcast. On main_nav.swf, it says podcast. Here, is says Podstar. Incorrect. --The Goblin!! 19:00, 29 July 2007 (UTC)

The feature is called Podstar Runner, though. --DorianGray 19:48, 29 July 2007 (UTC)
My bad. Fixed. --phlip TC 00:41, 30 July 2007 (UTC)
Yes, but if the purpose is to simulate the real main_mav bar, then it should be podcast. --The Goblin!! 01:24, 30 July 2007 (UTC)
Yes. That's why I fixed it. --phlip TC 01:26, 30 July 2007 (UTC)
Ah. You posted while I was still posting. --The Goblin!! 22:31, 31 July 2007 (UTC)

Just a question...

Are you ever going to put this in the Greasemonkey Script Repository? Just wondering... --Mario2.PNG Super Martyo boing! 18:54, 6 August 2007 (UTC)

Actually, that's the old Greasemonkey script place thing. The new one is at userscripts.org. Bluebry 19:00, 6 August 2007 (UTC)

not working

i installed greasemonkey but there isnt anything under tools. you do mean tools that is above the adress bar, right? Slipknot6477 22:57, 7 December 2007 (UTC)

Tablet stuff

Hey, this is a really neat script. Anyway, I use a tablet computer, and I've noticed that, when viewing a toon in portrait (tall) mode, the toon will cover up the top two buttons ("settings" and "wiki") if the script is set to scale the toon to full size. This is, I imagine, because the script expects the screen to be wider than it is tall, as most computer screens are... so when that is not the case, the toon sticks around the top of the page and covers up those key buttons. This doesn't happen in normal, "landscape" mode because the toon is horizontally centered across a wide screen. If the toon were vertically centered as well, or at least nudged sixteen pixels downward when on a tall screen, those buttons and their inherent usefulness would be unveiled for all. ("Landscape" mode is, of course, the better option for viewing Homestar Runner, but I think this would be a pretty good fix nonetheless.)

There are some other things: in Firefox 3.0 beta 4, the seek bar extends too far to the right, visually (covering up the buttons to its right), and does not seem to work for changing your place in the toon. Also, the script never seems to be able to load subtitles, perpetually leaving "loading" in place of subtitle options in the pulldown menu. Oh, and the "settings" bar has most of its scrollbar obscured by the toon, oddly, though it still works.

I hope this helps in working out any kinks. If nobody else can reproduce these errors, I can provide more details. Anyway, thanks!24.22.64.228 05:18, 2 April 2008 (UTC)

30 Frames fix?

For some reason, with the SBCG4AP "ad," the seek bar doesn't work at all. It counts the frame, but all the buttons (besides the zoom) doesn't work. --76.210.181.251 21:08, 10 April 2008 (UTC)

This has nothing to do with the high framerate (which is 24 anyway, not 30), and everything to do with the fact that the HTML file is on homestarrunner.com, but the flash file is on Telltale's servers... Flash's security gets in the way, and there's nothing that can be done about it. Best I can do is make it so that the seekbar is disabled on that toon (or, at least, make it more obvious that it's informative only, and you can't use it to control the playback). Which I'm working on. --phlip TC 04:53, 12 April 2008 (UTC)

3.2.3 broken in FF 2?

I can't get the subtitles if I upgrade to 3.2.3. I'm using FF 2. I see that it was changed for tweaks for Firefox 3...did you notice that it breaks it in FF 2? I don't think a version that breaks it in the current version of Firefox should be released to the update. --Mini-Geek 16:36, 9 June 2008 (UTC)

Oops... I didn't think to regression-test the changes in Fx 2... yeah, that doesn't work. The deal is that, in an earlier version of GreaseMonkey, DOMParser wasn't available for GM scripts to use... and you had to use some workaround to get at it. That workaround didn't work in Fx 3, but the site I got it from listed another option that did. Turns out that other option doesn't work in Fx 2. It also turns out that the workaround isn't necessary at all any more. It's gone now, and the script works in both Fx 2 and 3 (it should auto-update again in the next day or so). --phlip TC 08:55, 10 June 2008 (UTC)
Thanks, it works now. --Mini-Geek 14:26, 10 June 2008 (UTC)

Trouble dragging in FF3

If you try to drag the seek bar, but are already moving the mouse when you start dragging (move it faster if it doesn't do it for you), it messes up. By messes up, I mean it flashes the cursor between a circular crossout symbol and the normal cursor as you hold it down (still moving the movie as you move), then when you release, it keeps following your mouse until you click on it again. --Mini-Geek 20:04, 18 June 2008 (UTC)

Huh. That's... bizzare. I get a similar thing, but instead of the cursor-flashing thing you're saying, it actually starts dragging around a slightly-shrunk picture of the seekbar, and sometimes some of the surrounding buttons. I'll look into it (which I guess means I'll need to figure out how the drag-and-drop stuff in the seekbar actually works, since I didn't write that... that'll be "fun"). In the meantime: Don't do that. --phlip TC 08:55, 20 June 2008 (UTC)
"In the meantime: Don't do that." lol yeah...It's just that I do it accidentally pretty often now, and it's annoying. I'll try to avoid it in the meantime, though. Thanks for looking into it. --Mini-Geek 14:27, 20 June 2008 (UTC)
OK, this is fixed, I think. I never found a way to reproduce it reliably, but I think I could get it about one try in 3 or 4... and I tried about 20 times now, and I can't get it to happen... let me know if it still happens for you. --phlip TC 13:38, 25 June 2008 (UTC)
It seems to work now. It hasn't happened since I updated. The random button now shows the correct tooltip. --Mini-Geek 21:35, 26 June 2008 (UTC)

Plain HTML Rando Not Working in FF3?

I am finding if I used the plain HTML navbar with the script, it is not working and I get a dialog box saying "rando.xml has not loaded yet. Be Patient." from homestarrunner.com. Is this an issue with the official site, or did something in FF3 break it?— Bassbone (TALK Strong Mad Has a Posse CONT) 22:20, 22 June 2008 (UTC)

It works for me, but shows the wrong URL when I roll over it. --Mini-Geek 16:52, 23 June 2008 (UTC)
The wrong-URL thing should be fixed now. Things were happening in the wrong order... the tooltip and the page it would send you to if you clicked matched, but the URL in the status bar was from the previous selection... I tweaked the timing a bit, so this doesn't happen any more. I couldn't reproduce the infinite "has not loaded yet" thing... try clicking the "Clear Subtitles Cache" button in the preferences screen... the same button will clear the rando.xml cache, forcing it to really try again to download it from the server. --phlip TC 13:38, 25 June 2008 (UTC)

Subtitles broken

I'm on Firefox 3, with Adblock Plus (disabled on h*r.com and hrwiki.org), and the subtitles don't appear. I check "Show subtitles" in the options, and a list of languages appears, but when I go to anything that has subtitles - I tested it on Play Date - I get a "loading subtitles" message which disappears after a second or so. Other features like the seek bar work fine. Thanks in advance, 24.250.112.127 23:06, 1 July 2008 (UTC)

Works fine on 2.0.0.14, the latest stable build. I don't know if it's worth Phlip's time to develop for the beta, but you could revert to the stable build and it'll work. Qermaq - (T/C) Image:Qermaqsigpic.png 01:09, 2 July 2008 (UTC)
IP Guy: I had the same problem, but then I reinstalled the script and tested it by watching The Baloneyman, and now the subtitles work again.
Qermaq: the latest stable build is actually 3.0.0. --Y2K (15px-Crystal_Clear_app_xchat.png15px-Crystal_Clear_app_kedit.png15px-Crystal_Clear_app_email.png) 07:08, 2 July 2008 (UTC)
Well, what do you know, must have been quite recently. Qermaq - (T/C) Image:Qermaqsigpic.png 09:10, 2 July 2008 (UTC)
Update: I find the Greasemonkey extension is working flawlessly on my install of Firefox 3. Qermaq - (T/C) Image:Qermaqsigpic.png 16:42, 3 July 2008 (UTC)
I found that disabling AdBlock Plus for homestarrunner sites worked for me. --Rovlad.

I was about to report a problem with this, but I forgot about having to disable Adblock to get the subtitles working, even on the latest build. I'm installing Firefox in Ubuntu, and I though the crappy flash plugin was the problem.

Anyways, you may want to make this advice more prominent, in some sort of FAQ. (If you have already, well, I couldn't find it.)

--trlkly 23:48, 3 October 2008 (UTC)

How'd you get the icon data?

I noticed that your icons are embedded in the script as base64 data. If you used an encoder program, which one was it? --Y2K (15px-Crystal_Clear_app_xchat.png15px-Crystal_Clear_app_kedit.png15px-Crystal_Clear_app_email.png) 00:49, 13 July 2008 (UTC)

It's pretty simple... just convert the picture to PNG (I use The GIMP for that... any web-friendly image format will work, but PNG is best), then Base64-ify the PNG file (I just use the tool in coreutils), and tack "data:image/png;base64," on the start, then use the string as the URL for the image. Wikipedia has more info. I'm sure there exists some online tools that let you upload files and generate the data: URIs for them... try Google. --phlip TC 07:22, 13 July 2008 (UTC)

Seekbar

I can't get the seekbar to work. Every time I click anywhere on it it just goes back to the beginning of the toon. I know nothing about code, mind you, so I have no idea how to fix this. ~That Guy Over There (User talk:That Guy Over There) 02:32, 15 July 2008 (UTC)

Nevermind. I changed some of my Firefox settings and it works now. ~That Guy Over There (User talk:That Guy Over There) 02:37, 15 July 2008 (UTC)

what did you do, i have the same problem Forddude1416 19:20, 18 August 2008 (UTC)

Screencapture

How do I get a screen capture in Ubuntu Linux? --Blow Up the Ocean 20:50, 12 August 2008 (UTC)

This may vary (it's been a while since I used Gnome), but I believe that alt-Print Screen grabs the focused window, and Print Screen by itself grabs the entire desktop. It will either prompt you for a filename to save it as, or just save it automatically on your Desktop. It will be in PNG format, which is probably want you want.  Green Helmet 21:02, 12 August 2008 (UTC)

Test subtitles script and back button

I do a lot of subtitle work (the AIO makes it about a million times easier/possible, BTW :) ) and so I often use the "Test subtitles script" feature to preview my scripts before I save 'em. The problem is that I usually forget to uncheck the box, so when I go to another toon, it displays the wrong subtitles. Not a big deal, of course, as I can go into the options and uncheck the box, but it's an annoyance. It'd be nice if it automatically unchecks the box. Possibly make it uncheck when you load a different toon.
Also, if you have outside-the-frame action enabled and press the back/forward button (in the browser, not the next/previous button) to go to a page, it loads it full-screen instead of showing outside-the-frame action.
Oh and BTW I just noticed there's a feature to zoom in/out of the toon when it's full screened, but not when it shows outside-the-frame action. Can you add that feature in outside-the-frame mode, too? --Mini-Geekt c 16:22, 14 August 2008 (UTC)

The "Test subtitles script" option needs some serious rework anyway... I'd like the "Refresh subtitles" button to Just Work, rather than the sort of inconsistent mess it is now. Being able to give test subtitles for just one specific toon is a good idea... I'll add it to the list of things to do when I get around to doing that.
The back/forward buttons and outside-the-frame: I hadn't noticed that... I'll look into it. Does everything else work with back/forward?
As for the zoom buttons and outside-the-frame, if you use the Zoom things in Flash, then it stops doing the outside-the-frame thing... you can't zoom out further than how it behaves when you view the SWF alone (ie: either the height or width matches the height or width of your window, whichever is smaller)... and there's no way to go back to the outside-the-frame mode except by resetting it to the usual outside-the-frame size. I couldn't find any way around this... so I just got rid of the zoom buttons when that option's turned on. If you happen to know of a workaround, I'd love to hear it... --phlip TC 22:41, 14 August 2008 (UTC)
Ok, cool. I don't mean that I really care to see toon-specific subs that are remembered with different pages, in case that's what you thought. I just want it to be cleared when I go to a page besides the one being tested.
I haven't noticed anything else wrong with back/forward. I've noticed that when a page loads normally, it's momentarily enlarged to full screen before it's changed to show outside-the-frame, but that when you do back/forward it doesn't change. Perhaps it's something with how FF tells scripts that the page has loaded when it comes in from memory (since it was in recent history) instead of loading for the first time. I should probably also note that when it's zoomed out after going back/forward, I can still see outside-the-frame action, but of course since it's already full-screen, I only see it on the edges (instead of being like the normal full screen mode that puts black on the sides, this allows vision on the sides).
Do you think you could make it so if it's already at the max zoom out level, instead of just trying to tell the SWF to zoom out more (unsuccessfully), make it refresh as outside-the-frame in some way so it goes back out? Of course, that would preferably be without actually refreshing the page, so your place isn't lost like when you save a setting. This could eliminate the need for an outside-the-frame option, since if you want to zoom out when it's already all the way out, it goes to outside-the-frame, while zooming in while viewing outside-the-frame would go to full screen.
I just got an idea to fix the issue that when you save settings it refreshes the page (more of a workaround really, something that does it without refreshing at all would be better). Let it refresh, but first remember the frame you're at and the pause/unpause status (is there anything else that would be needed to make it seem the same?) and set it to that once it refreshes. --Mini-Geekt c 01:27, 15 August 2008 (UTC)

Latest java build

Seems this script is incompatable with the latest Java version. Qermaq - (T/C) Image:Qermaqsigpic.png 03:08, 27 August 2008 (UTC)

Can you be more specific? Neither this script, nor Homestarrunner.com use Java in any way...  Green Helmet 03:15, 27 August 2008 (UTC)
I beg to differ. I upgraded to the most recent Java and it asked me to deactivate this. I tied to reinstall, but it does not work. Qermaq - (T/C) Image:Qermaqsigpic.png 03:59, 27 August 2008 (UTC)
Can you still be more specific? Asked you to disabled this specific userscript, or Greasemonkey in general? Do you know the exact wording of the message? What version of Java did you update to? I just checked mine and it was at 1.6.0_04, there was an update available (to 1.6.0_07), which I just installed, restarted Firefox (and confirmed it was using the new version), and I did not see any change in the behaviour at all.
I'm still pretty sure Java isn't used directly here (in fact, I'm certain it isn't). But, it is possible that the Java installation changed something in the browsers security model that is messing things up. I'll try updating it on another computer tomorrow and see if I get the problem to happen there.  Green Helmet 05:07, 27 August 2008 (UTC)
Are you on a Mac? It appears to be broken on my Mac... but, it's past my bedtime right now.  Green Helmet 05:14, 27 August 2008 (UTC)
I am still unable to install this script. Qermaq - (T/C) Image:Qermaqsigpic.png 13:23, 5 September 2008 (UTC)
And I am still unable to even guess as to what your problem is... Can you answer GreenHelmet's questions above? They'll help narrow down the problem. --phlip TC 13:32, 5 September 2008 (UTC)
I am not certain how to check the Java version. I did go to the Java site and install the latest version. Greasemonkey itself seems to be properly installed, though I don't know how I can test that. Running Vista. Qermaq - (T/C) Image:Qermaqsigpic.png 18:54, 5 September 2008 (UTC)
Hmm... can you try something for me... run notepad, and type in this:
// ==UserScript==
// @name          GM Test Thing
// @description	  Check that Greasemonkey is working
// @include       http://homestarrunner.com/*
// @include       http://www.homestarrunner.com/*
// ==/UserScript==
alert("Greasemonkey's working");
Save it somewhere as "test.user.js" (include the quotes, when you type it into Notepad's "Save As" box, otherwise it'll save it as test.user.js.txt). Then open that file in Firefox, let it install the script, and go to HR:. You should get a message box coming up saying that GM's working. If not, there's something wrong with GM on your end... try uninstalling and reinstalling it. Otherwise, let me know, and I'll have to make a more detailed test. --phlip TC 03:44, 6 September 2008 (UTC)
I reinstalled Greasemonkey, and everything seems to be in order now. Something must have gotten goofed up on installation before. Thanks. Qermaq - (T/C) Image:Qermaqsigpic.png 03:03, 7 September 2008 (UTC)

Script doesn't seem to work

I'm running Firefox 3, and none of the buttons, scrollbar[s], or subtitles work. --Addict 2006 22:50, 10 October 2008 (UTC)

Hmm... could you try out the things listed in the brand new Troubleshooting section? --phlip TC 03:26, 11 October 2008 (UTC)
Phlip, maybe you should move step 3 up to step 1? It might save some people unnecessary work ;-) Loafing 16:27, 11 October 2008 (UTC)
Good point... --phlip TC 23:46, 11 October 2008 (UTC)

Yeah, Firefox 3 does have its own downs, because Adblock Plus doesn't conflict with the script in Firefox 2 but does in 3. --Addict 2006 19:27, 12 October 2008 (UTC)

Thank you!

This thing is awesome. HomsarGuy 13:16, 2 December 2008 (UTC)

Thanks and feature suggestion

Hey! Thanks for making this script! It really makes watching H*R much easier (and better)!
I would like to suggest a feature - it would be great to have an automatic 'next' feature to play through a whole series (like SBemail) or to play random through the whole site. This way we could watch sequential H*R without being near a mouse. (I don't know if this would infringe on the value of the SBemail DVDs) -Dutchscout 05:48, 5 December 2008 (UTC)

Page-Overwrite?

It's been on my mind lately; would it be possible to get the script to overwrite the loaded Flash file on a page, or just replace the content of a page without creating security issues with Flash? In some cases, it could be helpful, as with being able to run subtitles on certain Puppet Stuff toons that don't have their own HTML page, like Marshie vs. Little Girl. We could use default.html as a "dummy page", and using a URL referrer of "overwrite=whateverflashhere.swf" (which would be picked up by the script, not the page), would overwrite the page with your usual Homestar Runner toon-viewing code, with the Flash file in place of the usual "toon placeholder" itself? (I hope that made sense) --70.253.165.204 00:14, 6 December 2008 (UTC)

Script broke.

Your Greasemonkey script doesn't work. I am using Minefield 3.2a1pre and Flash Player 10. I also modified Greasemonkey to make it work with Minefield. Dagoth 08:11, 10 January 2009 (UTC)

Try everything in the Troubleshooting section. If that doesn't help, read through this and try again. Incidentally, "Minefield" has that codename for a reason... that Greasemonkey works at all (especially after you modified it) should be considered a stroke of luck. --phlip TC 08:17, 10 January 2009 (UTC)

2 things

1:Thanks!I really wanted a bigger screen. 2:Is it possible to make it work with the kitkorp mirror?

subtitles stopped working

I just noticed it today. I used it and it worked fine the other day. It seems that the script isn't finding the list of languages at Subtitles:Languages (the Subtitles Language select box doesn't have any entries). I do have AdBlock Plus but disabled it temporarily with no change. I'm using Firefox 3.0.11 with Greasemonkey 0.8.20090123.1 and the newest All-in-one script from User:Phlip/Greasemonkey (3.2.7). Perhaps it's related to "We will be making adjustments to the server throughout the evening, including upgrading to MediaWiki 1.15."? See also HRWiki_talk:Subtitles#Subitles_Not_Working? --Mini-Geekt c 03:11, 13 June 2009 (UTC)

It's related to the new upgrade and the move to the /wiki/ URLs... it should be fixed now. The script should automatically prompt you to update it sometime in the next day or so, or you can just hit the install link on the script page to do it yourself. If you're still not getting subtitles, it could be because you hit the "Save" or "Clear cache" buttons in the config panel while the subtitles were broken... in that case, just open up the config panel, make sure that the "language" option is set, and hit save. That should bring them back. --phlip TC 16:27, 13 June 2009 (UTC)
Thanks, it works now. :) --Mini-Geekt c 20:34, 13 June 2009 (UTC)
Personal tools